Logic 9.1.4 not totally compatible to Lion!?

Discussion of Apple Logic Pro, MainStage, GarageBand and all related applications

Logic 9.1.4 not totally compatible to Lion!?

Postby franky » Wed, 13 Jul 2011 3:25 am

Hi, just stumbled across this site:

http://roaringapps.com/

And it says there Logic 9.x is having some problems with Lion, what do you think, will they upgrade Logic or what is your impression?

best Regards, Frank
Macbook Pro Retina, Mac os 10.9.5, MiO ULN-8, MiO 2882, AMT8, Mackie Control Universal, Apogee One, Logic 10.x, Live 9.x, Lounge Lizard, Melodyne 3...
franky
 
Posts: 76
Joined: Thu, 30 Oct 2003 2:47 am
Location: Hamburg, Germany

Re: Logic 9.1.4 not totally compatible to Lion!?

Postby G » Wed, 13 Jul 2011 3:51 am

That site's Compatibility Table also indicates that Logic Pro and Logic Express are available on the Mac App Store, so... ;)

They will upgrade Logic if necessary. The question is more when than if.

Some plug-ins will have trouble with Lion. That's been chirping 'round the Intertubes for a few weeks now. A couple of the comments on roaringapps.com seem to confirm this (Logic 9.1.4 worked fine for one person without plug-ins). I've advised my local producer cabal to hold off on Lion for a couple of weeks while things settle down.

Another big issue will be the lack of Rosetta. I have some older apps (pre-2007 or so) that are about to reach a dead end because they lack an Intel version. There's no updating for them. It's over. Kaput. Luckily, it's almost all design stuff. Oh, and MS Office 2004.
Mac Pro (3,1 8-Core) . Radeon HD 5770 . MOTU 828mk3 . OS X Mavericks . Logic Pro X . FCPX . Get Info
User avatar
G
Owner/Admin
 
Posts: 2116
Joined: Mon, 05 May 2003 6:11 pm
Location: SF Bay Area, California

Re: Logic 9.1.4 not totally compatible to Lion!?

Postby 27 » Wed, 13 Jul 2011 8:06 pm

what's lion?

10.6.8 here and i'll be staying there for the foreseeable future. until every plug and app i use is up to 64 bit w/no problems i see no reason to move to a new OS. so, maybe 9-12 months or so from now at the earliest..and likely 18 months is more reasonable.

if it ain't broke...
27
 
Posts: 912
Joined: Thu, 30 Oct 2003 12:08 am
Location: portland

Re: Logic 9.1.4 not totally compatible to Lion!?

Postby jondl_2000 » Thu, 14 Jul 2011 10:17 am

27 wrote:what's lion?

10.6.8 here and i'll be staying there for the foreseeable future. until every plug and app i use is up to 64 bit w/no problems i see no reason to move to a new OS. so, maybe 9-12 months or so from now at the earliest..and likely 18 months is more reasonable.

if it ain't broke...


I don't disagree with your approach, this makes sense for many users. And I don't know that there will be a substantial leap forward in the migration to 64-bit audio apps with Lion, beyond the current pace of development, but I do think there is an opportunity to reassess with the elimination of Rosetta, i.e., no more backwards compatibility with PPC only apps.
jondl_2000
Site Supporter
 
Posts: 226
Joined: Fri, 12 Sep 2003 8:33 am
Location: Potomac Falls, Virginia

Re: Logic 9.1.4 not totally compatible to Lion!?

Postby WaveTable » Thu, 14 Jul 2011 12:55 pm

I don't see any point in upgrading to new version of OS X until they have been out for at least 6 months.
Asking for problems for Pro App users!
Logic Pro 9, Live 8.
WaveTable
 
Posts: 273
Joined: Thu, 30 Jul 2009 3:40 am

Re: Logic 9.1.4 not totally compatible to Lion!?

Postby gdoubleyou » Sun, 24 Jul 2011 9:08 am

I installed it on an external drive.

Running Logic in 32bit mode, Automat, and Plugsound pro, are the only AU that didn't pass AU eval.
Haven't checked for updates yet.

iLok apps seem to work, Melodyne standalone work, haven't tested the plug.

All Pace installers and PPC apps have been tombstoned.

Only apps I lost were the apps bundled with my Epson printer.

8)
G-Dub

2GHz quad i7 MBP
Logic 9.1.8, LPX.0.4, OSX 10.8.5
Apollo Duo
User avatar
gdoubleyou
 
Posts: 1455
Joined: Fri, 20 Sep 2002 4:09 pm
Location: kirkland WA

Re: Logic 9.1.4 not totally compatible to Lion!?

Postby gdoubleyou » Sun, 24 Jul 2011 10:47 am

gdoubleyou wrote:I installed it on an external drive.

Running Logic in 32bit mode, Automat, and Plugsound pro, are the only AU that didn't pass AU eval.
Haven't checked for updates yet.

iLok apps seem to work, Melodyne standalone work, haven't tested the plug.

All Pace installers and PPC apps have been tombstoned.

Only apps I lost were the apps bundled with my Epson printer.

8)


Plugsoung Pro is discontinued, but you can upgrade your libraries to the UVI soundcard format and use the FREE UVI workstation for playback.

Automat has been updated and works fine.

:ass: :rockon:
G-Dub

2GHz quad i7 MBP
Logic 9.1.8, LPX.0.4, OSX 10.8.5
Apollo Duo
User avatar
gdoubleyou
 
Posts: 1455
Joined: Fri, 20 Sep 2002 4:09 pm
Location: kirkland WA


Return to Logic Studio



Who is online

Users browsing this forum: No registered users and 3 guests